I fully recognize how nerdy this is, but still…

Ok. I was surfing around a bit, and spotted this dice.com banner ad.

First of all, threshold = salary_sucks? That doesn’t even make sense. In my mind, a threshold is some point that has been reached. And so presumably, if you’ve got a sucky salary… it’s not as though it’s something that finally happened. It’s not as if you suddenly got a sucky salary – it’s always been that way.

How about something more like if (problem = salary_sucks) or if (salary = sucks)? Doesn’t that make a bit more sense?

Second of all, isn’t it one equal sign for assigning a value, and two equal signs for testing equivalency? Shouldn’t it in fact be if (threshold == salary_sucks)? A really small point perhaps, but keep in mind this is a banner ad trying to attract people to tech jobs.

What’s the big deal between one and two equal signs? Well, it’s a painful lesson I’ve learned many, many times in the past. Something a small as this can make or break your app, and cause no end of headaches.


Looking over the entries for today, I realize I’ve analyzed the effectiveness of Grey Poupon’s tagline and critiqued random code that appeared on a banner ad.

*pushes glasses up with index finger*

That’s right. The chicks? They dig me.

This Post Has 0 Comments

Leave A Reply